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UNIT-IV
Rich Internet Applications (RIAS) with Adobe Flash
Adobe Flash Introduction:
Adobe Flash CS3 (Creative Suite 3) is a commercial application that you can use to produce interactive, animated movies.
Flash can be used to create web-based banner advertisements, interactive websites, games and web-based applications with
stunning graphics and multimedia effects. It provides tools for drawing graphics, generating animations, and adding sound
and video. Flash movies can be embedded in web pages, distributed on CDs and DVDs as independent applications, or
converted into stand-alone, executable programs. Flash includes tools for coding in its scripting language—ActionScript
3.0—which is similar to JavaScript and enables interactive applications. A fully functional, 30-day trial version of Flash
CS3 is available for download from:
www.adobe.com/products/flash/
To follow along with the examples in this chapter, please install this software before continuing. Follow the on-screen
instructions to install the trial version of the Flash software. To play Flash movies, the Flash Player plug-in must be
installed in your web browser. The most recent version of the plug-in (at the time of this writing) is version 9. You can
download the latest version from:
www.adobe.com/go/getflashplayer
According to Adobe’s statistics, approximately 98.7 percent of web users have Flash Player version 6 or greater installed,
and 83.4 percent of web users have Flash Player version 9 installed.1 There are ways to detect whether a user has the
appropriate plug-in to view Flash content. Adobe provides a tool called the Flash PlayerDetection Kit which contains files
that work together to detect whether a suitable version of Adobe Flash Player is installed in a user’s web browser. This kit
can be downloaded from:
www.adobe.com/products/flashplayer/download/detection_kit/
This chapter introduces building Flash movies. You’ll create interactive buttons, add sound to movies, create special
graphic effects and integrate ActionScript in movies.

Flash Movie Development:
Once Flash CS3 is installed, open the program. Flash’s Welcome Screen appears by default. The Welcome Screen
contains options such as Open a Recent Item, Create New and Create from Template. The bottom of the page contains
links to useful help topics and tutorials. [Note: For additional help, refer to Flash’s Help menu.]
To create a blank Flash document, click Flash File (ActionScript 3.0) under the Create New heading. Flash opens a new
file called Untitled-1 in the Flash development environment (Fig. 14.1).
At the center of the development environment is the movie stage—the white area in which you place graphic elements
during movie development. Above the stage is the timeline,which represents the time period over which a movie runs. The
timeline is divided into increments called frames, represented by gray and white rectangles. Each frame depicts a moment
in time during the movie, into which you can insert movie elements. The playhead indicates the current frame.

Common Programming Error:
Elements placed off stage can still appear if the user changes the aspect ratio of the movie. If anelement should not be
visible, use an alpha of 0% to hide the element.
The development environment contains several windows that provide options andtools for creating Flash movies. Many of
these tools are located in the Tools bar, the verticalwindow located at the left side of the development environment. The
Tools bar(Fig. 14.2) is divided into multiple sections, each containing tools and functions that helpyou create Flash movies.
The tools near the top of the Tools bar select, add and removegraphics from Flash movies. The Hand and Zoom tools
allow you to pan and zoom in thestage. Another section of tools provides colors for shapes, lines and filled areas. The
lastsection contains settings for the active tool (i.e., the tool that is highlighted and in use).You can make a tool behave
differently by selecting a new mode from the options sectionof the Tools bar.
Application windows called panels organize frequently used movie options. Paneloptions modify the size, shape, color,
alignment and effects associated with a movie’sgraphic elements. By default, panels line the right and bottom edges of the
window. Panels
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may be placed anywhere in the development environment by dragging the tab at the left edge of their bars.
The context-sensitive Properties panel (frequently referred to as the Properties window) is located at the bottom of the
screen by default. This panel displays various information about the currently selected object. It is Flash’s most useful tool
for viewing and altering an object’s properties.
The Color, Swatches, Properties, Filters and Parameters panels also appear in the development environment by default.
You can access different panels by selecting them from the Window menu. To save and manage customized panel layouts,
select Window > Workspace, then use the Save Current… and Manage… options to save a layout or load an existing
layout, respectively.

Learning Flash with Hands-On Examples:
Now you’ll create several complete Flash movies. The first example demonstrates how to create an interactive, animated
button. ActionScript code will produce a random text string each time the button is clicked. To begin, create a new Flash
movie. First, select File > New. In the New Document dialog (Fig. 14.3), select Flash File (ActionScript 3.0) under the
General tab and click OK. Next, choose File > Save As… and save the movie as Ceo- Assistant.fla. The .fla file extension
is a Flash-specific extension for editable movies.
Good Programming Practice
Save each project with a meaningful name in its own folder. Creating a new folder for each movie helps keep projects
organized.
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Right click the stage to open a menu containing different movie options. Select Document Properties… to display the
Document Properties dialog (Fig. 14.4). This dialog can also be accessed by selecting Document… from the Modify
menu. Settings such as the Frame rate, Dimensions and Background color are configured in this dialog.

The Frame rate sets the speed at which movie frames display. A higher frame rate causes more frames to be displayed in a
given unit of time (the standard measurement is seconds), thus creating a faster movie. The frame rate for Flash movies on
the web is generally between 12 and 60 frames per second (fps). Flash’s default frame rate is 12 fps. For this example, set
the Frame Rate to 10 frames per second.
Performance Tip
Higher frame rates increase the amount of information to process, and thus increase the movie’s processor usage and file
size. Be especially aware of file sizes when catering to low bandwidth web users.
The background color determines the color of the stage. Click the background-color box (called a swatch) to select the
background color. A new panel opens, presenting a websafe palette. Web-safe palettes and color selection are discussed in
detail in Chapter 3. Note that the mouse pointer changes into an eyedropper, which indicates that you may select a color.
Choose a light blue color (Fig. 14.5).
The box in the upper-left corner of the dialog displays the new background color. The hexadecimal notation for the
selected color appears to the right of this box. The hexadecimal notation is the color code that a web browser uses to render
color.

Dimensions define the size of the movie as it displays on the screen. For this example, set the movie width to 200 pixels
and the movie height to 180 pixels. Click OK to apply the changes in the movie settings.

Software Engineering Observation
A movie’s contents are not resized when you change the size of the movie stage.
With the new dimensions, the stage appears smaller. Select the Zoom Tool from the toolbox (Fig. 14.2) and click the stage
once to enlarge it to 200 percent of its size (i.e., zoom in). The current zoom percentage appears in the upper-right above
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the stage editing area. Editing a movie with small dimensions is easier when the stage is enlarged. Press the Alt key while
clicking the zoom tool to reduce the size of the work area (i.e., zoom out). Select the Hand Tool from the toolbox, and drag
the stage to the center of the editing area. The hand tool may be accessed at any time by holding down the spacebar key.

Creating a Shape with the Oval Tool
Flash provides several editing tools and options for creating graphics. Flash creates shapes using vectors—mathematical
equations that Flash uses to define size, shape and color. Some other graphics applications create raster graphics or
bitmapped graphics. When vector graphics are saved, they are stored using equations. Raster graphics are defined by areas
of colored pixels—the unit of measurement for most computer monitors. Raster graphics typically have larger file sizes
because the computer saves the information for every pixel. Vector and raster graphics also differ in their ability to be
resized. Vector graphics can be resized without losing clarity, whereas raster graphics lose clarity as they are enlarged or
reduced.
We’ll now create an interactive button out of a circular shape. You can create shapes by dragging with the shape tools.
Select the Oval tool from the toolbox. If the Oval tool is not already displayed, click and hold the Rectangle/Oval tool to
display the list of rectangle and oval tools. We use this tool to specify the button area. Every shape has a Stroke color and a
Fill color. The stroke color is the color of a shape’s outline, and the fill color is the color that fills the shape. Click the
swatches in the Colors section of the toolbox (Fig. 14.6) to set the fill color to red and the stroke color to black. Select the
colors from the web-safe palette or enter their hexadecimal values.
Clicking the Black and white button resets the stroke color to black and the fill color to white. Selecting the Swap colors
option switches the stroke and fill colors. A shape can be created without a fill or stroke color by selecting the No color
option ( ) when you select either the stroke or fill swatch.
Create the oval anywhere on the stage by dragging with the Oval tool while pressing the Shift key. The Shift key constrains
the oval’s proportions to have equal height and

width (i.e., a circle). The same technique creates a square with the Rectangle tool or draws a straight line with the Pencil
tool. Drag the mouse until the circle is approximately the size of a dime, then release the mouse button.
After you draw the oval, a dot appears in frame 1, the first frame of the timeline for Layer 1. This dot signifies a keyframe
(Fig. 14.7), which indicates a point of change in a timeline. Whenever you draw a shape in an empty frame, Flash creates a
keyframe.
The shape’s fill and stroke may be edited individually. Click the red area with the Selection tool (black arrow) to select the
circle fill. A grid of white dots appears over an object when it is selected (Fig. 14.8). Click the black stroke around the
circle while pressing the Shift key to add to this selection. You can also make multiple selections by dragging with the
selection tool to draw a selection box around specific items.
A shape’s size can be modified with the Properties panel when the shape is selected (Fig. 14.9). If the panel is not open,
open it by selecting Properties from the Window menu or pressing <Ctrl>-F3.
Set the width and height of the circle by typing 30 into the W: text field and 30 into the H: text field. Entering an equal
width and height maintains a constrained aspect ratio while changing the circle’s size. A constrained aspect ratio maintains
an object’s proportions as it is resized. Press Enter to apply these values.
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The next step is to modify the shape’s color. We’ll apply a gradient fill—a gradual progression of color that fills the shape.
Open the Swatches panel (Fig. 14.10), either by selecting Swatches from the Window menu or by pressing <Ctrl>-F9.
The Swatches panel provides four radial gradients and three linear gradients, although you also can create and
edit gradients with the Color panel.
Click outside the circle with the Selection tool to deselect the circle. Now, select only the red fill with the Selection tool.
Change the fill color by clicking the red radial gradient fill in the Swatches panel. The gradient fills are located at the
bottom of the Swatches panel (Fig. 14.10). The circle should now have a red radial gradient fill with a black stroke
surrounding it.

Adding Text to a Button
Button titles communicate a button’s function to the user. The easiest way to create a title is with the Text tool. Create a
button title by selecting the Text tool and clicking the center of the button. Next, type GO in capital letters. Highlight the
text with the Text tool. Once text is selected, you can change the font, text size and font color with the Properties window
(Fig. 14.11). Select a sans-serif font, such as Arial or Verdana, from the font dropdown list. Set the font size to 14 pt either
by typing the size into the font size field or by pressing the arrow button next to it, revealing the size selection slider—a
vertical slider that, when moved, changes the font size. Set the font weight to bold by clicking the bold

button (B). Finally, change the font color by clicking the text color swatch and selecting white from the palette.

Look-and-Feel Observation:
Sans-serif fonts, such as Arial, Helvetica and Verdana, are easier to read on a computer monitor, and therefore ensure
better usability.
If the text does not appear in the correct location, drag it to the center of the button with the Selection tool. The button is
almost complete and should look similar to Fig. 14.12.
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Converting a Shape into a Symbol:
A Flash movie consists of scenes and symbols. Each scene contains all graphics and symbols. The parent movie may
contain several symbols that are reusable movie elements, such as graphics, buttons and movie clips. A scene timeline can
contain numerous symbols, each with its own timeline and properties. A scene may have several instances of any given
symbol (i.e., the same symbol can appear multiple times in one scene). You can edit symbols independently of the scene by
using the symbol’s editing stage. The editing stage is separate from the scene stage and contains only one symbol.

Good Programming Practice:
Reusing symbols can drastically reduce file size, thereby allowing faster downloads.
To make our button interactive, we must first convert the button into a button symbol. The button consists of distinct text,
color fill and stroke elements on the parent. stage. These items are combined and treated as one object when the button is
converted into a symbol. Use the Selection tool to drag a selection box around the button, selecting the button fill, the
button stroke and the text all at one time (Fig. 14.13).
Now, select Convert to Symbol… from the Modify menu or use the shortcut F8 on the keyboard. This opens the Convert
to Symbol dialog, in which you can set the properties of a new symbol (Fig. 14.14).
Every symbol in a Flash movie must have a unique name. It is a good idea to name symbols by their contents or function,
because this makes them easier to identify and reuse. Enter the name go button into the Name field of the Convert to
Symbol dialog. The Behavior option determines the symbol’s function in the movie.
You can create three different types of symbols—movie clips, buttons and graphics.A movie clip symbol’s behavior is
similar to that of a scene and thus it is ideal for recurring animations. Graphic symbols are ideal for static images and basic
animations. Button symbols are objects that perform button actions, such as rollovers and hyperlinking. A rollover is an
action that changes the appearance of a button when the mouse passes over it. For this example, select Button as the type
of symbol and click OK. The button should now be surrounded by a blue box with crosshairs in the upper-left corner,
indicating that the button is a symbol. Also, in the Properties window panel, name this instance of the go button symbol
goButton in the field containing <Instance Name>. Use the selection tool to drag the button to the lower-right corner of
the stage.
The Library panel (Fig. 14.15) stores every symbol present in a movie and is accessed through the Window menu or by
the shortcuts <Ctrl>-L or F11. Multiple instances of a symbol can be placed in a movie by dragging and dropping the
symbol from the Library panel onto the stage.
The Movie Explorer displays the movie structure and is accessed by selecting Movie Explorer from the Window menu or
by pressing <Alt>-F3 (Fig. 14.16). The Movie Explorer panel illustrates the relationship between the current scene (Scene
1) and its symbols.
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Editing Button Symbols
The next step in this example is to make the button symbol interactive. The different components of a button symbol, such
as its text, color fill and stroke, may be edited in the symbol’s editing stage, which you can access by double clicking the
icon next to the symbol in the Library. A button symbol’s timeline contains four frames, one for each of the button states
(up, over and down) and one for the hit area.
The up state (indicated by the Up frame on screen) is the default state before the user presses the button or rolls over it with
the mouse. Control shifts to the over state (i.e., the Over frame) when the user rolls over the button with the mouse cursor.
The button’s down state (i.e., the Down frame) plays when a user presses a button. You can create interactive, userresponsive buttons by customizing the appearance of a button in each of these states. Graphic elements in the hit state (i.e.,
the Hit frame) are not visible to a viewer of the movie; they exist simply to define the active area of the button (i.e., the
area that can be clicked). The hit state will be discussed further in Section 14.6.
By default, buttons have only the up state activated when they are created. You may activate other states by adding
keyframes to the other three frames. Keyframes for a button, discussed in the next section, determine how a button reacts
when it is rolled over or clicked with the mouse.

Adding Keyframes:
Keyframes are points of change in a Flash movie and appear in the timeline with a dot. By adding keyframes to a button
symbol’s timeline, you can control how the button reacts to user interactions. The following step shows how to create a
button rollover effect, which is accomplished by inserting a keyframe in the button’s Over frame, then changing the
button’s appearance in that frame. Right click the Over frame and select Insert Keyframe from the resulting menu or press
F6 (Fig. 14.18).
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Select the Over frame and click outside the button area with the selection tool to deselect the button’s components. Change
the color of the button in the Over state from red gradient fill to green gradient fill by selecting only the fill portion of the
button with the Selection tool. Select the green gradient fill in the Swatches panel to change the color of the button in the
Over state. Changing the color of the button in the over state does not affect the color of the button in the up state. Now,
when the user moves the cursor over the button (in the up state) the button animation is replaced by the animation in the
Over state. Here, we change only the button’s color, but we could have created an entirely new animation in the Over state.
The button will now change from red to green when the user rolls over the button with the mouse. The button will return to
red when the mouse is no longer positioned over the button.

Publishing Your Flash Movie:
Flash movies must be published for users to view them outside the Flash CS3 environment and Flash Player. This section
discusses the more common methods of publishing Flash movies. For this example, we want to publish in two formats,
Flash and Windows Projector, which creates a standard Windows-executable file that works even if the user hasn’t
installed Flash. Select Publish Settings… from the File menu to open the Publish Settings dialog.
Select the Flash, HTML and Windows Projector checkboxes and uncheck all the others. Then click the Flash tab at the
top of the dialog. This section of the dialog allows you to choose the Flash settings. Flash movies may be published in an
older Flash version if you wish to support older Flash Players. Note that ActionScript 3.0 is not supported by older
players, so choose a version with care. Publish the movie by clicking Publish in the Publish Settings dialog or by selecting
Publish from the File menu. After you’ve published the movie, the directory in which you saved the movie will have
several new files (Fig. 14.30). If you wish to place your movie on a website, be sure to copy the HTML, JavaScript and
SWF files to your server.
Good Programming Practice:
It is not necessary to transfer the .fla version of your Flash movie to a web server unless you want other users to be able to
download the editable version of the movie.
As we can see in the Ceo Assistant 1.0 example, Flash is a feature-rich program. We have only begun to use Flash to its full
potential. ActionScript can create sophisticated programs and interactive movies. It also enables Flash to interact with
ASP.NET (Chapter 21), PHP (Chapter 19), and JavaScript (Chapters 4–9), making it a program that integrates smoothly
into a web environment.
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Creating Special Effects with Flash:
The following sections introduce several Flash special effects. The preceding example familiarized you with basic movie
development. The next sections cover many additional topics, from importing bitmaps to creating splash screens that
display before a web page loads.
Importing and Manipulating Bitmaps
Some of the examples in this chapter require importing bitmapped images and other media into a Flash movie. The
importing process is similar for all types of media, including images, sound and video. The following example shows how
to import an image into a Flash movie.
Begin by creating a new Flash document. The image we are going to import is located in the Chapter 14 examples folder.
Select File > Import > Import to Stage… (or press <Ctrl>-R) to display the Import dialog. Browse to the folder on your
system containing this chapter’s examples and open the folder labeled images. Select bug.bmp and click OK to continue. A
bug image should appear on the stage. The Library panel stores imported images. You can convert imported images into
editable shapes by selecting the image and pressing <Ctrl>-B or by choosing Break Apart from the Modify menu. Once
an imported image is broken apart, it may be shape tweened or edited with editing tools, such as the Lasso, Paint bucket,
Eraser and Paintbrush. The editing tools are found in the toolbox and apply changes to a shape. Dragging with the Lasso
tool selects areas of shapes.
The color of a selected area may be changed or the selected area may be moved. Click and drag with the Lasso tool to
draw the boundaries of the selection. As with the button in the last example, when you select a shape area, a mesh of white
dots covers the selection. Once an area is selected, you may change its color by selecting a new fill color with the fill
swatch or by clicking the selection with the Paint bucket tool. The Lasso tool has different options (located in the Options
section of the toolbox) including Magic wand and Polygon mode. The Magic wand option changes the Lasso tool into the
Magic wand tool, which selects areas of similar colors. The polygonal lasso selects straight-edged areas.
The Eraser tool removes shape areas when you click and drag the tool across an area. You can change the eraser size using
the tool options. Other options include settings that make the tool erase only fills or strokes.
The Brush tool applies color in the same way that the eraser removes color. The paintbrush color is selected with the fill
swatch. The paintbrush tool options include a Brush mode option. These modes are Paint behind, which sets the tool to
paint only in areas with no color information; Paint selection, which paints only areas that have been selected; and Paint
inside, which paints inside a line boundary.
Each of these tools can create original graphics. Experiment with the different tools to change the shape and color of the
imported bug graphic.
Creating an Advertisement Banner with Masking:
Masking hides portions of layers. A masking layer hides objects in the layers beneath it, revealing only the areas that can
be seen through the shape of the mask. Items drawn on a masking layer define the mask’s shape and cannot be seen in the
final movie. The next example, which builds a website banner, shows how to use masking frames to add animation and
color effects to text.
Create a new Flash document and set the size of the stage to 470 pixels wide by 60 pixels high. Create three layers named
top, middle and bottom according to their positions in the layer hierarchy. These names help track the masked layer and
the visible layers. The top layer contains the mask, the middle layer becomes the masked animation and the bottom layer
contains an imported bitmapped logo. Import the graphic bug_apple.bmp (from the images folder in this chapter’s
examples folder) into the first frame of the top layer, using the method described in the preceding section. This image will
appear too large to fit in the stage area. Select the image with the selection tool and align it with the upper-left corner of the
stage. Then select the Free transform tool in the toolbox (Fig. 14.31).
The Free transform tool allows us to resize an image.When an object is selected with this tool, anchors appear around its
corners and sides. Click and drag an anchor to resize the image in any direction. Holding the Shift key while dragging a
corner anchor ensures
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that the image maintains the original height and width ratio. Hold down the Shift key while dragging the lower-right anchor
upward until the image fits on the stage.
Use the text tool to add text to frame 1 of the top layer. Use Verdana, 28 pt bold, as the font. Select a blue text color, and
make sure that Static Text is selected in the Properties window. Type the banner text “Deitel and Associates”, making
sure that the text fits inside the stage area, and use the Selection tool to position the text next to the image. This
text becomes the object that masks an animation.
We must convert the text into a shape before using it as a mask. Click the text field with the Selection tool to ensure that it
is active and select Break Apart twice from the Modify menu. Breaking the text apart once converts each letter into its
own text field. Breaking it apart again converts the letters into shapes that cannot be edited with the text tool, but can be
manipulated as regular graphics.
Copy the contents of the top layer to the bottom layer before creating themask, so that the text remains visible when the
mask is added. Right click frame 1 of the top layer, and select Copy Frames from the resulting menu. Paste the contents of
the top layer into frame 1 of the bottom layer by right clicking frame 1 of the bottom layer and selecting Paste Frames
from the menu. This shortcut pastes the frame’s contents in the same positions as the original frame. Delete the extra copy
of the bug image by selecting the bug image in the top layer with the selection tool and pressing the Delete key.
Next, you’ll create the animated graphic that the banner text in the top layer masks. Click in the first frame of the middle
layer and use the Oval tool to draw a circle to the left of the image that is taller than the text. The oval does not need to fit
inside the banner area. Set the oval stroke to no color by clicking the stroke swatch and selecting the No color option. Set
the fill color to the rainbow gradient (Fig. 14.32), found at the bottom of the
Swatches panel.
Select the oval by clicking it with the Selection tool, and convert the oval to a symbol by pressing F8. Name the symbol
oval and set the behavior to Graphic. When the banner is complete, the oval will move across the stage; however, it will be
visible only through the text mask in the top layer. Move the oval just outside the left edge of the stage, indicating the point
at which the oval begins its animation. Create a keyframe in frame 20 of the middle layer and another in frame 40. These
keyframes indicate the different locations of the oval symbol during the animation. Click frame 20 and move the oval just
outside

the right side of the stage to indicate the animation’s next key position. Do not move the position of the oval graphic in
frame 40, so that the oval will return to its original position at the end of the animation. Create the first part of the
animation by right clicking frame 1 of the middle layer and choosing Create Motion Tween from the menu. Repeat this
step for frame 20 of the middle layer, making the oval symbol move from left to right and back. Add keyframes to frame
40 of both the top and bottom layers so that the other movie elements appear throughout the movie.
Now that all the supporting movie elements are in place, the next step is to apply the masking effect. To do so, right click
the top layer and select Mask (Fig. 14.33). Adding a mask to the top layer masks only the items in the layer directly below
it (the middle layer), so the bug logo in the bottom layer remains visible at all times. Adding a mask also locks the top and
middle layers to prevent further editing.
Now that the movie is complete, save it as banner.fla and test it with the Flash Player. The rainbow oval is visible through
the text as it animates from left to right. The text in the bottom layer is visible in the portions not containing the rainbow
(Fig. 14.34).
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Adding Online Help to Forms
In this section, we build on Flash techniques introduced earlier in this chapter, including tweening, masking, importing
sound and bitmapped images, and writing ActionScript. In the following example, we apply these various techniques to
create an online form that offers interactive help. The interactive help consists of animations that appear when a user
presses buttons located next to the form fields. Each button contains a script that triggers an animation, and each animation
provides the user with information regarding the form field that corresponds to the pressed button.
Each animation is a movie-clip symbol that is placed in a separate frame and layer of the scene. Adding a stop action to
frame 1 pauses the movie until the user presses a button.
Begin by creating a new movie, using default movie size settings. Set the frame rate to 24 fps. The first layer will contain
the site name, form title and form captions. Change the name of Layer 1 to text. Add a stop action to frame 1 of the text
layer. Create the site name Bug2Bug.com as static text in the text layer using a large, bold font, and place the title at the top
of the page. Next, place the form name Registration Form as static text beneath the site name, using the same font, but in a
smaller size and different color. The final text element added to this layer is the text box containing the form labels. Create
a text box using the Text Tool, and enter the text: Name:, Member #: and Password:, pressing Enter after entering each
label to put it on a different line. Next, adjust the value of the Line Spacing field (the amount of space between lines of
text) found by clicking the Edit Format Options button ( ) in the Properties window. Change the form field caption line
spacing to 22 in the Format Options dialog (Fig. 14.35) and set the text alignment (found in the Properties window) to
right justify.
Now we’ll create the form fields for our help form. The first step in the production of these form fields is to create a new
layer named form. In the form layer, draw a rectangle that is roughly the same height as the caption text. This rectangle
will serve as a background for the form text fields (Fig. 14.36).We set a Rectangle corner radius of 6 px in the Properties
panel. Feel free to experiment with other shapes and colors.
The next step is to convert the rectangle into a symbol so that it may be reused in the movie. Select the rectangle fill and
stroke with the selection tool and press F8 to convert the selection to a symbol. Set the symbol behavior to Graphic and
name the symbol form

field. This symbol should be positioned next to the Name: caption. When the symbol is in place, open the Library panel
by pressing <Ctrl>-L, select the form layer and drag two copies of the form field symbol from the Library onto the stage.
This will create two new instances of this symbol. Use the Selection tool to align the fields with their corresponding
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captions. For more precise alignment, select the desired object with the Selection tool and press the arrow key on the
keyboard in the direction you want to move the object. After alignment of the form field symbols, the movie should
resemble Fig. 14.37.
We now add input text fields to our movie. An input text field is a text field into which the user can enter text. Select the
Text tool and, using the Properties window, set the font to Verdana, 16 pt, with dark blue as the color. In the Text type
pull-down menu in the Properties window, select Input Text (Fig. 14.38). Then, click and drag in the stage to create a text
field slightly smaller than the form field symbol we just created. With the Selection tool, position the text field over the
instance of the form field symbol associated with the name. Create a similar text field for member number and password.
Select the Password text field, and select Password in the Line type pull-down menu in the Properties window. Selecting
Password causes any text entered into the field by the user to appear as an asterisk (*). We have now created all the input
text fields for our help form. In this

example, we won’t actually process the text entered into these fields. Using ActionScript, we could give each input text
field a variable name, and send the values of these variables to a server-side script for processing.
Now that the form fields are in place, we can create the help associated with each field. Add two new layers. Name one
layer button and the other labels. The labels layer will hold the frame label for each keyframe. A frame label is a text
string that corresponds to a specific frame or series of frames. In the labels layer, create keyframes in frames 2, 3 and 4.
Select frame 2 and enter name into the Frame field in the Properties window (Fig. 14.39).

The movie is now complete. Press <Ctrl>-Enter to preview it with the Flash Player. If the triggered animations do not
appear in the correct locations, return to the scene and adjust their position. The final movie is displayed in Fig. 14.46. In
our example, we have added a picture beneath the text layer. Movies can be enhanced in many ways, such as by changing
colors and fonts or by adding pictures. Our movie (bug2bug.fla) can be found in the this chapter’s examples directory. If
you want to use our symbols to recreate the movie, select Open External Library… from the Import submenu of the File
menu and open bug2bug.fla. The Open External Library… option allows you to reuse symbols from another movie.
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Creating a Website Splash Screen:
Flash is becoming an important tool for e-businesses. Many organizations use Flash to create website splash screens (i.e.,
introductions), product demos and web applications. Others use Flash to build games and interactive entertainment in an
effort to attract new visitors. However, these types of applications can take a long time to load, causing visitors—
especially those with slow connections—to leave the site. One way to alleviate this problem is to provide visitors with an
animated Flash introduction that draws and keeps their attention. Flash animations are ideal for amusing visitors while
conveying information as the rest of a page downloads “behind the scenes.”
A preloader or splash screen is a simple animation that plays while the rest of the web page is loading. Several techniques
are used to create animation preloaders. The following example creates an animation preloader that uses ActionScript to
pause the movie at a particular frame until all the movie elements have loaded. To start building the animation preloader,
create a new Flash document. Use the default size, and set the background color to a light blue. First, you’ll create the
movie pieces that will be loaded later in the process. Create five new layers, and rename Layer 2 to C++, Layer 3 to Java
and Layer 4 to IW3. Layer 5 will contain the movie’s ActionScript, so rename it actions. Because Layer 1 contains the
introductory animation, rename this layer animation.
The preloaded objects we use in this example are animated movie clip symbols. Create the first symbol by clicking frame 2
of the C++ layer, inserting a keyframe, and creating a new movie-clip symbol named cppbook. When the symbol’s editing
stage opens, import the image cpphtp.gif (found in the images folder with this chapter’s examples). Place a keyframe in
frame 20 of Layer 1 and add a stop action to this frame. The animation in this example is produced with the motion tween
Rotate option, which causes an object to spin on its axis. Create a motion tween in frame 1 with the Properties window,
setting the Rotate option to CCW (counterclockwise) and the times field to 2 (Fig. 14.47). This causes the image
cpphtp.gif to spin two times counterclockwise over a period of 20 frames.
After returning to the scene, drag and drop a copy of the cppbook symbol onto the stage in frame 2 of the C++ layer. Move
this symbol to the left side of the stage. Insert a frame in frame 25 of the C++ layer.
Build a similar movie clip for the Java and IW3 layers, using the files java.gif and iw3.gif to create the symbols. Name the
symbol for the Java layer jbook and the IW3 symbol ibook to identify the symbols with their contents. In the main scene,
create a keyframe in frame 8 of the Java layer, and place the jbook symbol in the center of the stage. Insert a frame in
frame 25 of the Java layer. Insert the ibook symbol in a keyframe in frame 14 of the IW3 layer, and position it to the right
of the jbook symbol. Insert a frame in frame 25 of the IW3 layer. Make sure to leave some space between these symbols so
that they will not overlap when they spin (Fig. 14.48). Add a keyframe to the 25th frame of the actions layer, then add a
stop to the Actions panel of that frame.
Now that the loading objects have been placed, it is time to create the preloading animation. By placing the preloading
animation in the frame preceding the frame that contains the objects, we can use ActionScript to pause the movie until the
objects have loaded. Begin by adding a stop action to frame 1 of the actions layer. Select frame 1 of the animation layer
and create another new movie-clip symbol named loader. Use the text tool with a medium-sized sans-serif font, and place
the word Loading in the center of the symbol’s
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editing stage. This title indicates to the user that objects are loading. Insert a keyframe into frame 14 and rename this layer
load.
Create a new layer called orb to contain the animation. Draw a circle with no stroke about the size of a quarter above the
word Loading. Give the circle a green-to-white radial gradient fill color. The colors of this gradient can be edited in the
Color panel (Fig. 14.49). The block farthest to the left on the gradient range indicates the innermost color of the radial
gradient, whereas the block farthest to the right indicates the outermost color of the radial gradient. Click the left block to
reveal the gradient color swatch. Click the swatch and select a medium green as the inner color of the gradient. Select the
right, outer color box and change its color to white. Deselect the circle by clicking on a blank portion of the stage. Note that
a white ring appears around the circle due to the colored background. To make the circle fade into the background, we
adjust its alpha value. Alpha is a value between 0 and 100% that corresponds to a color’s transparency or opacity. An alpha
value of 0% appears transparent, whereas a value of 100% appears completely opaque. Select the circle again and click the
right gradient box (white). Adjust the value of the Alpha field in the Color Mixer panel to 0%. Deselect the circle. It
should now appear to fade into the background.
The rate of progression in a gradient can also be changed by sliding the color boxes. Select the circle again. Slide the left
color box to the middle so that the gradient contains more green than transparent white, then return the slider to the far left.
Intermediate colors may be added to the gradient range by clicking beneath the bar, next to one of the existing.

color boxes. Click to the right of the inner color box to add a new color box (Fig. 14.50). Slide the new color box to the
right and change its color to a darker green. Any color box may be removed from a gradient by dragging it downward off
the gradient range.
Insert keyframes into frame 7 and 14 of the orb layer. Select the circle in frame 7 with the selection tool. In the Color
panel change the alpha of every color box to 0%. Select frame 1 in the Timeline and add shape tween. Change the value of
the Ease field in the Properties window to –100. Ease controls the rate of change during tween animation. Negative values
cause the animated change to be gradual at the beginning and become increasingly drastic. Positive values cause the
animation to change quickly in the first frames, becoming less drastic as the animation progresses. Add shape tween to
frame 7 and set the Ease value to 100. In frame 14, add the action gotoAndPlay(1); to repeat the animation. You can
preview the animation by pressing Enter. The circle should now appear to pulse.
Before inserting the movie clip into the scene, we are going to create a hypertext linked button that will enable the user to
skip over the animations to the final destination. Add a new layer called link to the loader symbol with keyframes in
frames 1 and 14. Using the text tool, place the words skip directly to Deitel website below Loading in a smaller font size.
Select the words with the selection tool and convert them into a button symbol named skip. Converting the text into a
button simulates a text hyperlink created with XHTML. Double click the words to open the skip button’s editing stage. For
this example, we are going to edit only the hit state. When a button is created from a shape, the button’s hit area is, by
default, the area of the shape. It is important to change the hit state of a button created from text so that it includes the
spaces between the letters; otherwise, the link will work only when the user hovers over a letter’s area. Insert a keyframe in
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the hit state. Use the rectangle tool to draw the hit area of the button, covering the entire length and height of the text. This
rectangle is not visible in the final movie, because it defines only the hit area (Fig. 14.51).
The button is activated by giving it an action that links it to another web page. After returning to the loader movie-clip
editing stage, give the skip button the instance name skipButton and open the Actions panel for the first frame of the link
layer. Invoke the add- EventListener function using the skipButton instance to call function onClick whenever

the button is clicked. Then, create an object of type URLRequest and give the constructor a parameter value of
"http://www.deitel.com". The function onClick employs Flash’s navigateToURL function to access the website given to it.
Thus, the code now reads
skipButton.addEventListener( MouseEvent.CLICK, onClick );
var url : URLRequest = new URLRequest( "http://www.deitel.com" );
function onClick( e : MouseEvent ) : void
{
navigateToURL( url, "_blank" );
} // end function onClick
The "_blank" parameter signifies that a new browser window displaying the Deitel website should open when the user
presses the button. Return to the scene by clicking Scene 1 directly below the timeline, next to the name of the current
symbol. Drag and drop a copy of the loader movie clip from the Library panel into frame 1 of the animation layer, center
it on the stage, and set its Instance name to loadingClip.
The process is nearly complete. Open the Actions panel for the actions layer. The following actions direct the movie clip to
play until all the scene’s objects are loaded. First, add a stop to the frame so that it doesn’t go to the second frame until we
tell it to. Using the loadingClip movie instance, use the addEventListener function to invoke the functiononBegin
whenever the event Event.ENTER_FRAME is triggered. The ENTER_FRAME event occurs every time the playhead
enters a new frame. Since this movie’s frame rate is 12 fps (frames per second), the ENTER_FRAME event will occur 12
times each second.
loadingClip.addEventListener( Event.ENTER_FRAME, onBegin );
The next action added to this sequence is the function onBegin. The condition of the if statement will be used to determine
how many frames of the movie are loaded. Flash movies load frame by frame. Frames that contain complex images take
longer to load. Flash will continue playing the current frame until the next frame has loaded. For our movie, if the number
of frames loaded (frameLoaded) is equal to the total number of frames (totalFrames), then the movie is finished loading, so
it will play frame 2. It also invokes the removeEventListener function to ensure that onBegin is not called for the remainder
of the movie. If the number of frames loaded is less than the total number of frames, then the current movie clip continues
to play. The code now reads:
stop();
loadingClip.addEventListener( Event.ENTER_FRAME, onBegin );
// check if all frames have been loaded
function onBegin( event : Event ) : void
{
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if ( framesLoaded == totalFrames )
{
loadingClip.removeEventListener( Event.ENTER_FRAME, onBegin );
gotoAndPlay( 2 );
} // end if
} // end function onBegin
Create one more layer in the scene, and name the layer title. Add a keyframe to frame 2 of this layer, and use the Text tool
to create a title that reads Recent Deitel Publications. Below the title, create another text hyperlink button to the Deitel
website. The simplest way to do this is to duplicate the existing skip button and modify the text. Right click the skip
symbol in the Library panel, and select Duplicate. Name the new button visit, and place it in frame 2 of the title layer.
Label the instance visitButton, then create a keyframe in the second frame of the actions layer. Duplicate the code from
the Actions panel of the first frame of the link layer in the loader symbol, and replace skipButton with visit- Button.
Double click the visit button and edit the text to say visit the Deitel website. Add keyframes to each frame of the title layer
and manipulate the text to create a typing effect similar to the one we created in the bug2bug example.
The movie is now complete. Test the movie with the Flash Player (Fig. 14.52). When viewed in the testing window, the
loading sequence will play for only one frame because your processor loads all the frames almost instantly. Flash can
simulate how amovie would appear to an online user, though. While still in the testing window, select 56K from the
Download Settings submenu of the View menu. Also, select Bandwidth Profiler from the View menu. Then select
Simulate Download from the View menu or press <Ctrl>-Enter. The graph at the top of the window displays the amount
of bandwidth required to load each frame.

ActionScript:
Figure 14.53 lists common Flash Action Script 3.0 functions. By attaching these functions to frames and symbols, you can
build some fairly complex Flash movies.
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